Que se passe-t'il si on installe WordPress avec PHP 5 et le niveau d'erreur E_STRICT ? Ça affiche ceci :

Strict Standards: Assigning the return value of new by reference is deprecated in /var/www/wordpress/wp-settings.php on line 264

C'est un problème connu qui serait dû aux différences entre les versions de PHP. Peu importe la raison, une erreur qui apparaît dés l'installation (rendant impossible l'identification dans l'interface d'administration), ça ne fait pas très sérieux. Un test de la version permettrait peut-être d'utiliser la syntaxe appropriée à chaque version de PHP.

Le problème se résout en remplaçant =& new par = new dans wp-settings.php.